View unanswered posts | View active topics It is currently Tue Mar 31, 2020 3:12 am

Reply to topic  [ 5 posts ] 
Help With Uploading to the Workshop 
Author Message

Joined: Fri Sep 25, 2015 4:01 pm
Posts: 3
Reply with quote
So I've been working on a mod, and I've gotten it to the point where I want to put it on the workshop. When I first uploaded it, it was missing a thumbnail, so after a bit of research, I deleted the mod from the workshop to re-upload it with a "preview.png" (simply updating the mod from the in-game mod menu wouldn't work, and in order to get the game to forget that it had uploaded a previous version of the mod, I removed the mod's entry from the Saved Games/Reassenbly/mods folder). When I tried to upload the mod with the preview file("preview.png", resolution 400x400 pixels), the message next to the mod's entry in the in-game mod menu said "FileNotFound//File was not found"(or something to that extent), and the workshop page it opened was blank, with an error saying the file didn't exist, and that it may have been removed by the author. What file it was talking about, I don't know, but I assumed that it's referring to the workshop page. After several failed attempts to get the mod to upload, I removed the thumbnail image from the mod's file, and the mod appeared to upload properly(minus the thumbnail, of course), but after a complaint of the mod not working by a friend, I subscribed to the mod myself and found that the file it dropped to the steamapps/workshop/content/329130 file contained only the ID text file, and not any of the mod(blocks.lua, factions.lua, etc.). I've re-attemped to upload it(with the thumbnail file), resulting in the usual error, and have provided the resulting log_latest.txt file below.

If anyone needs additional information, log files, etc., just let me know.

thanks in advance, and any help with this is appreciated.

log_latest.txt [33.02 KiB]
Downloaded 213 times
Fri Sep 25, 2015 4:27 pm

Joined: Mon May 04, 2015 10:08 am
Posts: 97
Reply with quote
I did the same thing with all 3 of my mods...uploaded them, decided I didn't want them up just yet or needed to change something, and removed them from Steam. The 2nd and 3rd time I felt pretty dumb for not remembering the pains of having already made that mistake the first time around.

So the solution I eventually found to deal with that is to remove the steam_id file (and in your case you should probably re-remove your mod from the workshop) and rename the folder in your mods directory even just slightly, then re-upload. This method worked just fine for me.

For instance, I uploaded a mod with a folder named "Heirs to the Void - The Shadows Have Eyes..." and then removed it from Steam. After feeling dumb for having made the mistake a 3rd time, I remembered what I need to do and changed the file folder's name to "Heirs to the Void Ep. 2 - The Shadows Have Eyes..." and re-uploaded. At that point, Steam saw it as a different mod entirely and allowed it back on the Workshop.

Sat Oct 10, 2015 11:26 am

Joined: Fri Sep 25, 2015 4:01 pm
Posts: 3
Reply with quote
Ok, I tried that, but something didn't work. Most likely me just misreading your instructions.

1. I went on to the workshop page for the broken upload and deleted it.
2. I deleted the "Saved Games/Reassembly/mods/The DroneLords Faction" file.
3. I went to "steamapps/common/reassemby/mods" and changed the name of the mods file from The DroneLords Faction to The DroneLords Custom Faction
4. I entered the game, saw that the mod was loaded(with the new name, was labeled as "local", and that the entry for the previous published name was gone), and hit publish.

After a couple seconds of progress bars and debug text as usual, it gave me a the FileNotFound error again and proceeded to open the new broken page in my browser. I deleted the broken page and removed the new "Saved Games/Reassembly/mods/The DroneLords Custom Faction" file.

Most likely I deleted the wrong file or something, but thanks for the advice anyway.

I've grabbed an excerpt from the log file, the part where it tries to upload the mod:

[SDL] texture has 3 colors, 400x400 pixels

[MODS] Loading preview from mods/The DroneLords Custom Faction/preview.png: OK (400x400)
[MODS] Creating Steam Workshop item for mod 'The DroneLords Custom Faction'
[STEAM] OneMod::OnCreateItemResult('The DroneLords Custom Faction') -> OK // success
[MODS] Saved Steam Published File ID 538260048 to mods/The DroneLords Custom Faction/steam_pfid.txt: OK
[MODS] ISteamUGC::SetItemTitle(The DroneLords Custom Faction) OK
[MODS] ISteamUGC::SetItemVisibility(Public) OK
Listing mods/The DroneLords Custom Faction: 6 files (1 local)
[MODS] ISteamUGC::SetItemTags(blocks, ships, map, factions) OK
[MODS] ISteamUGC::SetItemContent(C:\Users\<User>\Saved Games\Reassembly\mods\The DroneLords Custom Faction/) OK
[MODS] ISteamUGC::SetItemPreview(C:\Users\<User>\Saved Games\Reassembly\mods\The DroneLords Custom Faction\preview.png) OK
[STEAM] OneMod::OnSubmitItemUpdateResult('The DroneLords Custom Faction') -> FileNotFound // file was not found

Mon Oct 19, 2015 4:55 pm

Joined: Mon May 04, 2015 10:08 am
Posts: 97
Reply with quote
Hmm...yeah, reading your step by step and then looking back at my instructions I realize I wasn't too clear.

The folder you wanted to rename is located here:

c:\users\your user name\saved games\reassembly\mods <----- The mods folder I was talking about.

The one you deleted from this folder was the one that needed to be renamed, the other one could have been deleted.

My apologies for the confusion :(

Tue Oct 20, 2015 6:34 pm

Joined: Fri Sep 25, 2015 4:01 pm
Posts: 3
Reply with quote
Sorry, but I don't think I quite understand...

I had deleted the saved games file after every attempt, so it wasn't there to rename. I went in game, upload the mod again(failed as usual), then went back to the saved games file and renamed the file there in the same way as before(but in the saved games folder as you said). When I went back in game, there were 2 copies of the mod loaded, both published. I tried to update the correct one(the one with the thumbnail), but failed again.

After this test, I deleted the page from the workshop and the "Saved Games/mods/The DroneLords Faction" folder again...

Sorry about the confusion, but what did I mess-up/misinterpret this time?

Thanks again.

Sat Oct 24, 2015 7:45 am
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software