Anisoptera Games
https://www.anisopteragames.com/forum/

Shield regen in tournament mode?
https://www.anisopteragames.com/forum/viewtopic.php?f=4&t=7813
Page 1 of 1

Author:  MonsPubis [ Fri Jul 14, 2017 4:12 pm ]
Post subject:  Shield regen in tournament mode?

I'm not entirely sure this is a bug as opposed to specifically designed functionality, but I'd like to see it changed nonetheless.

Shields in tournament mode don't seem to work as specified. A ship with a large farmer shield (600 regen/sec and more than enough power to run it) was unable to sustain fire from a ship with 480 dps output. It took approximately 12 seconds to kill the ship, meaning the shield was about 25% of its listed regen. It's expected that 600 shield regen/sec should be able to sustain damage from a 480 dps ship indefinitely. Reports indicate it also continues to drain energy at the full rate (600/sec in this case).

No CVAR seems to modify this value, leading me to believe it's hard coded. It also seems you cannot disconnect shield regen from energy consumption, meaning we can't 'fix' this in a tournament-focused balance mod, either. Can we please get this behavior changed so shields work as one would expect?

Video evidence: https://youtu.be/Azwki_bAzXk

Author:  Lilyan [ Sat Jul 15, 2017 10:57 pm ]
Post subject:  Re: Shield regen in tournament mode?

kSlowGrowRate = 0.2

change this to 1 and shield regen will be normal in tournament mode.
It also affects blocks regen.

Author:  MonsPubis [ Sun Jul 16, 2017 3:27 am ]
Post subject:  Re: Shield regen in tournament mode?

Ah, yup, that did the trick. I would never have guessed that's what that CVAR did.

Much appreciated.

Author:  Aleksander Wit [ Thu Sep 14, 2017 9:29 am ]
Post subject:  Re: Shield regen in tournament mode?

To make shields usable then you COULD make this 1.5-2.0 or something..

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/